CRM Snap for Office 2007

Aug 23, 2007 at 7:44 PM
The CRM Snap 1.5 version installation requires Office 2003. When is support for Office 2007 planned for?
Thanks,
Adriana